This project is read-only.

PKS Podcast Detail Page not working

Dec 15, 2009 at 3:54 PM

Hello. When I go to the PKS Podcast detail page the only thing showing up is the comments box. When I click "Make it Compatible with SIlverlight I receive an error message that the "length" is null or not an object.

When I edit the page the webpart says that "This query has returned no items"

I have tried installing this 4 times and everytime receive the same error message. Also I have checked that the files are being uploaded to the upload folder which they are. However I did notice that the CsId is not be generated in the list.  It is on the file that is in the folder. The Media Encoder Service works and is started. Lastly I am not getting a thumbnail or the duration when a file is uploaded. I checked the settings for those and they are correct based on the  install file. I am using Server 2003 Moss 2007 and the August release of podcast. Sql 2005.

Thanks for any help.

Dec 16, 2009 at 4:12 AM

Hi

Can youc heck wkether media encoder service is started or not?

Because this behavior is seen if Csid is not generated. media encoder servcie generates the csid. IF service is working you can see thumbnail, duration and size of item on homepage.

Also you can check whether files are getting uploaded on physical location or not, if files are not getting uploaded then delete virtual folder "UploadFolder from IIS and create new one do an iisreset and try again.

If files are getting uploaded then you can check media encoder configurations

onfig file in c:\Program Files\PKS\Media encoder service

also entries in lists PKS Configuration settings, Media encoder monitor locations.

for all these configurations you can refer "Installation and Configuration Guide for PKS.docx"

please check all configurations related to media encoder services mentioned above. this should solve your problem.

Jeff

 

Dec 17, 2009 at 1:43 PM

I checked all the settings and everything seems fine. THe Media Encoder Service is running and files are being uploaded. Pasted below is the config file and the two log files. There is an error showing in both log files.

MediaEncoderService.exe.config

<?xml version="1.0" encoding="utf-8" ?>

<configuration>

<system.serviceModel>

<bindings />

<client />

</system.serviceModel>

<appSettings>

<add key="configWeb" value="http://samhc25069:9946" />

<add key="configList" value="PKS Configuration Settings" />

<add key="externalStoresList" value="PKS Media Encoder Monitor Locations" />

</appSettings>

</configuration>

 

Encoder.log

[12/15/2009 9:13:16 AM] GetListItem entered

[12/15/2009 9:13:17 AM] Item created: %7bc9425dd1-21da-4df3-b7ec-385b70c9ba30%7d%40%7b5ffbd919-3046-4f93-bb68-e065f58a0a97%7d@2

[12/15/2009 9:58:45 AM] GetListItem entered

[12/15/2009 9:58:46 AM] Item created: %7bc9425dd1-21da-4df3-b7ec-385b70c9ba30%7d%40%7b5ffbd919-3046-4f93-bb68-e065f58a0a97%7d@3

[12/15/2009 9:58:46 AM] Item isPrimary...

[12/15/2009 9:58:46 AM] GenerateThumbnail() entered...

[12/15/2009 9:58:46 AM] Audio file type supported...

[12/15/2009 9:58:46 AM] Error[fileSystemWatcher_Created]: Could not load file or assembly 'Microsoft.Expression.Encoder, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

StackTrace:

at MediaEncoderService.Recode.GetDuration(String file)

at MediaEncoderService.PKSListItem.GetDuration(String file)

at MediaEncoderService.PKSListItem.GenerateThumbnail()

at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)

[12/15/2009 10:00:48 AM] GetListItem entered

[12/15/2009 10:00:49 AM] Item created: %7bc9425dd1-21da-4df3-b7ec-385b70c9ba30%7d%40%7b5ffbd919-3046-4f93-bb68-e065f58a0a97%7d@3

[12/15/2009 10:00:49 AM] Item isPrimary...

[12/15/2009 10:00:49 AM] GenerateThumbnail() entered...

[12/15/2009 10:00:49 AM] Audio file type supported...

[12/15/2009 10:00:49 AM] Error[fileSystemWatcher_Created]: Could not load file or assembly 'Microsoft.Expression.Encoder, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

StackTrace:

at MediaEncoderService.Recode.GetDuration(String file)

at MediaEncoderService.PKSListItem.GetDuration(String file)

at MediaEncoderService.PKSListItem.GenerateThumbnail()

at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)

 

 

Config.log

[12/15/2009 8:15:10 AM] Reading configuration...

[12/15/2009 8:15:10 AM] configWeb=http://samhc25069:9946

[12/15/2009 8:15:10 AM] configList=PKS Configuration Settings

[12/15/2009 8:15:10 AM] externalStoresList=PKS Media Encoder Monitor Locations

[12/15/2009 8:15:11 AM] Loading configuration from list web service...

[12/15/2009 8:15:11 AM] Configuration web service for 'PKS Configuration Settings' values have changed.

[12/15/2009 8:15:11 AM] Loading external file stores from list web service...

[12/15/2009 8:15:11 AM] External File Stores web service values have changed.

[12/15/2009 8:15:11 AM] Adding section c9425dd1-21da-4df3-b7ec-385b70c9ba305ffbd919-3046-4f93-bb68-e065f58a0a97

[12/15/2009 8:15:11 AM] Loading auto encode from list web service...

[12/15/2009 8:15:11 AM] Auto encode web service request failed.

[12/15/2009 8:40:40 AM] Reading configuration...

[12/15/2009 8:40:40 AM] configWeb=http://samhc25069:9946

[12/15/2009 8:40:40 AM] configList=PKS Configuration Settings

[12/15/2009 8:40:40 AM] externalStoresList=PKS Media Encoder Monitor Locations

[12/15/2009 8:40:41 AM] Loading configuration from list web service...

[12/15/2009 8:40:41 AM] Configuration web service for 'PKS Configuration Settings' values have changed.

[12/15/2009 8:40:41 AM] Loading external file stores from list web service...

[12/15/2009 8:40:41 AM] External File Stores web service values have changed.

[12/15/2009 8:40:41 AM] Adding section c9425dd1-21da-4df3-b7ec-385b70c9ba305ffbd919-3046-4f93-bb68-e065f58a0a97

[12/15/2009 8:40:41 AM] Loading auto encode from list web service...

[12/15/2009 8:40:41 AM] Auto encode web service request failed.

 

Dec 18, 2009 at 4:00 AM

Hi,

From logs it seems that you have not installed Expression encoder 3, if this is correct? please install Expression encoder 3.

One try, try to uninstall and install service again.

Hope this helps.

Jeff

Dec 18, 2009 at 1:23 PM

I have Expression Encoder 2 installed. I have tried it with 2 and 3.  Neither one generates the missing .dll. from the encoder log.

Dec 19, 2009 at 3:17 AM

Hi

PKS team have provided seprate MEdai encoder service for EE2 and EE3, make sure that respective encoder servicesa are installed then your service will work fine and you wont get error.

Jeff