This project is read-only.

Error loading Ratings component

Oct 26, 2009 at 8:07 PM

Hello all.  I am attempting an install of August 2009 and am getting an error with Ratings.  When I attempt to go to the Podcast Details page (or even the Podcast Files list), I get an error dialog titled "Message from webpage" with error text of "Service does not exist".  I click OK on that and get another dialog titled "Message from webpage" with NO text in it.  I click OK to that and then the page loads with no Ratings component loaded on the page.  What is happening?  I've got the usual suspects created (farm feature turned on, ratings turned on in the PKS Podcasts list, etc.).  Any ideas out there?

 

Jason

Oct 26, 2009 at 10:22 PM

After a bit more digging, I get an message in the Event Viewer (not flagged as an error) from SPP Ratings stating "EVENT FAILURE IN WEB APP".  Come to find out, none of the ratings webparts are "really" loaded (they say they are there but selecting them gives a "File Not Found" error).  There is also no other errors displayed in the ssm.log file (looks like everything works).  So it seems Ratings is completely inoperable for me right now.  I've done numerous installs on PKS on this VM (always from scratch) so I don't think it is environmental (Windows 2003 Server).  Suggestions would be helpful.

Nov 30, 2009 at 9:37 AM

Hi Jason,

I guess your PKS application's web.config is missing an entry related to the Ratings component in the HttpHandler section.

You can try adding the following entry under HttpHandler section:

<add path="*.Ratings/*,*.Ratings/*/*,*.Ratings/*/*/*,*.Ratings/*/*/*/*,*.Ratings/*/*/*/*/*,*.Ratings/*/*/*/*/*/*" type="Microsoft.MSIT.Ratings.Web.WebService.HttpHandler,Microsoft.MSIT.Ratings.Web, Version=1.0.0.0, Culture=neutral,PublicKeyToken=039e36666027bfc6" verb="*" />

Hope this helps.

-Parag