This project is read-only.

Problem with search results and scopes in August release

Sep 14, 2009 at 1:27 PM

Hi, i've successfully gone through the installation for a subsite and am able to upload, rate, download track, play etc various podcasts.

I've got to the point where I've created the search scopes, however if I go to the home page of my subsite, i don't see any list of scopes, just the text box and the magnifying glass? So my first problem is how do i change the scope for the search.

 If I enter a search term it insists on navigating to the route of the site collection to look for the podcast results page, rather than the subsite. Its correcty configured at the site collection root to point to /sub site name/pages. If i manually change the url in the navigation bar to point to the sub site, the results appear fine. I just can't get the search box to take me to the right location for the results page?

Anyone else had this?

Sep 14, 2009 at 1:54 PM

Did a bit of digging and the problem was in the PKSMasterPage.master. The javascript function Search() defined at the top of the master page was trying to fine the page at /Pages/PodcastSearchResults.aspx which is actually going to navigate you to the root site. Changing the url to PodcastSearchResults.aspx causes it to look within the current Pages library.

With regards to selecting the scope, the same search function is hardcoded to Podcasts, so a new control would need to be added to allow for selection if required. I don't really need this but thats what you would need to do to enable it.

Nov 10, 2009 at 12:06 AM

I'm assuming you are talking about line 96?  You changed:

var searchURL = "/Pages/PodcastSearchResults.aspx?k=" + encodeURIComponent(searchtext) + "&s=Podcasts";

to:

var searchURL = "PodcastSearchResults.aspx?k=" + encodeURIComponent(searchtext) + "&s=Podcasts";

Everytime I do this I get a "Page Not Found" when I go to my sub-site's main page.  I have even tried to "re-hardcode" it so that is says /subsite/Pages/....  Always get the same error.  Just making sure I'm following what you did.  I did have some custom permissions on this site so that could be wrecking me too.

 

Thanks!