Errors in the encoder log file after uploading the video

Aug 18, 2009 at 11:58 AM

Hi,

   I'm installing the PKS may version.I have installed all the prerequisites.I have also completed all the installation steps till "Pages Configuration".While testing the Media Encoder Service by uploading a media file the video is getting uploaded but I'm not getting the Thumbnails or anything else about the video.I saw the encoder file which was as follows.

 

 

[8/18/2009 2:56:31 AM] Error[LoadExternalStores]: No configuration values found
[8/18/2009 2:56:31 AM] Setting up file system monitor...
[8/18/2009 2:56:32 AM] Error[LoadExternalStores]: No configuration values found
[8/18/2009 3:04:42 AM] Error[fileSystemWatcher_Created]: Index was outside the bounds of the array.
StackTrace:
   at MediaEncoderService.PKSListItem..ctor(String path, MEConfig meConfig, Recode Recoder)
   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)
[8/18/2009 3:04:42 AM] Error[fileSystemWatcher_Created]: Object reference not set to an instance of an object.
StackTrace:
   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)
[8/18/2009 3:04:42 AM] Error[fileSystemWatcher_Created]: Object reference not set to an instance of an object.
StackTrace:
   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)
[8/18/2009 3:04:42 AM] GetListItem entered
[8/18/2009 3:04:44 AM] Item created: %7b745751e6-47b4-4be4-982d-bb49d19e9fd7%7d%40%7bd807e569-de01-478d-8b99-07fcfb2a1f70%7d@1
[8/18/2009 3:04:44 AM] Item isPrimary...
[8/18/2009 3:04:44 AM] GenerateThumbnail() entered...
[8/18/2009 3:04:44 AM] Video file type supported...
[8/18/2009 3:04:44 AM] executing recoder.Thumbnail()...
[8/18/2009 3:04:44 AM] Error[fileSystemWatcher_Created]: Could not load file or assembly 'Microsoft.Expression.Encoder, Version=2.0.1406.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
StackTrace:
   at MediaEncoderService.Recode.Thumbnail(String mediaPath, String outputPath, TimeSpan& duration)
   at MediaEncoderService.PKSListItem.GenerateThumbnail()
   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)

[8/18/2009 2:56:31 AM] Error[LoadExternalStores]: No configuration values found

 

[8/18/2009 2:56:31 AM] Setting up file system monitor...

[8/18/2009 2:56:32 AM] Error[LoadExternalStores]: No configuration values found

 

[8/18/2009 3:04:42 AM] Error[fileSystemWatcher_Created]: Index was outside the bounds of the array.

StackTrace:

   at MediaEncoderService.PKSListItem..ctor(String path, MEConfig meConfig, Recode Recoder)

   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)

 

[8/18/2009 3:04:42 AM] Error[fileSystemWatcher_Created]: Object reference not set to an instance of an object.

StackTrace:

   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)

 

[8/18/2009 3:04:42 AM] Error[fileSystemWatcher_Created]: Object reference not set to an instance of an object.

StackTrace:

   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)

 

[8/18/2009 3:04:42 AM] GetListItem entered

[8/18/2009 3:04:44 AM] Item created: %7b745751e6-47b4-4be4-982d-bb49d19e9fd7%7d%40%7bd807e569-de01-478d-8b99-07fcfb2a1f70%7d@1

[8/18/2009 3:04:44 AM] Item isPrimary...

[8/18/2009 3:04:44 AM] GenerateThumbnail() entered...

[8/18/2009 3:04:44 AM] Video file type supported...

[8/18/2009 3:04:44 AM] executing recoder.Thumbnail()...

[8/18/2009 3:04:44 AM] Error[fileSystemWatcher_Created]: Could not load file or assembly 'Microsoft.Expression.Encoder, Version=2.0.1406.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

StackTrace:

   at MediaEncoderService.Recode.Thumbnail(String mediaPath, String outputPath, TimeSpan& duration)

   at MediaEncoderService.PKSListItem.GenerateThumbnail()

   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)

 

 

I did not enter the configuration values as i do not want the iTunes support.So, I ignored the "No configuration value" error.Can anyone please help me out.Thank you.

 

Aug 19, 2009 at 6:35 AM

Hi,

From the following error it seems that the Microsoft Expression Encoder is not installed properly or has been corrupted.

[8/18/2009 3:04:44 AM] Error[fileSystemWatcher_Created]: Could not load file or assembly 'Microsoft.Expression.Encoder, Version=2.0.1406.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

Can you remove it and install it again and test after restarting the Media Encoder Service?

-Parag

Aug 19, 2009 at 10:27 AM

Hi paragk,

              Thanks a lots for your reply.I have not installed Expression Encoder at all since I do not want the iTune support.Is it necessary to install it if even if you do not want the iTunes support???

 

 

Aug 19, 2009 at 11:24 AM

Hi paragk,

              Thanks a lots now am able to upload the file and am play it also but am getting a small error in the encoder log file.Here is my encoder log file.

 

[8/19/2009 3:20:23 AM] Error[fileSystemWatcher_Created]: Object reference not set to an instance of an object.
StackTrace:
   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)
[8/19/2009 3:20:23 AM] GetListItem entered
[8/19/2009 3:20:25 AM] Item created: %7b745751e6-47b4-4be4-982d-bb49d19e9fd7%7d%40%7bd807e569-de01-478d-8b99-07fcfb2a1f70%7d@3
[8/19/2009 3:20:25 AM] Item isPrimary...
[8/19/2009 3:20:25 AM] GenerateThumbnail() entered...
[8/19/2009 3:20:25 AM] Video file type supported...
[8/19/2009 3:20:25 AM] executing recoder.Thumbnail()...
[8/19/2009 3:20:29 AM] Thumbnail generated...
[8/19/2009 3:20:29 AM] Thumbnail created...
[8/19/2009 3:20:30 AM] Update[UpdateListItem] 0x00000000
[8/19/2009 3:20:30 AM] New item values calculated...
[8/19/2009 3:20:30 AM] Auto encode rules have been run...
[8/19/2009 3:20:30 AM] GetListItem entered
[8/19/2009 3:20:31 AM] Item created: %7b745751e6-47b4-4be4-982d-bb49d19e9fd7%7d%40%7bd807e569-de01-478d-8b99-07fcfb2a1f70%7d@3

[8/19/2009 3:20:23 AM] Error[fileSystemWatcher_Created]: Object reference not set to an instance of an object.

StackTrace:

   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)

 

[8/19/2009 3:20:23 AM] GetListItem entered

[8/19/2009 3:20:25 AM] Item created: %7b745751e6-47b4-4be4-982d-bb49d19e9fd7%7d%40%7bd807e569-de01-478d-8b99-07fcfb2a1f70%7d@3

[8/19/2009 3:20:25 AM] Item isPrimary...

[8/19/2009 3:20:25 AM] GenerateThumbnail() entered...

[8/19/2009 3:20:25 AM] Video file type supported...

[8/19/2009 3:20:25 AM] executing recoder.Thumbnail()...

[8/19/2009 3:20:29 AM] Thumbnail generated...

[8/19/2009 3:20:29 AM] Thumbnail created...

[8/19/2009 3:20:30 AM] Update[UpdateListItem] 0x00000000

[8/19/2009 3:20:30 AM] New item values calculated...

[8/19/2009 3:20:30 AM] Auto encode rules have been run...

[8/19/2009 3:20:30 AM] GetListItem entered

[8/19/2009 3:20:31 AM] Item created: %7b745751e6-47b4-4be4-982d-bb49d19e9fd7%7d%40%7bd807e569-de01-478d-8b99-07fcfb2a1f70%7d@3

I do not know why am getting the error "Öbject referrence not set to an instance of an object".Should I just avoid this error??

 

Aug 24, 2009 at 1:27 PM

Please, Help me

I'm installing the PKS July version.I have installed all the prerequisites.I have also completed all the installation steps.While testing the Media Encoder Service by uploading a media file the video is getting uploaded but I'm not getting the Thumbnails or anything else about the video.I saw the encoder file which was as follows.

[8/24/2009 2:59:40 PM] Error[fileSystemWatcher_Created]: Object reference not set to an instance of an object.
StackTrace:
   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)

[8/24/2009 2:59:40 PM] GetListItem entered
[8/24/2009 2:59:42 PM] Item created: %7b7d5db985-93f8-4661-8ffa-612090a8eec3%7d%40%7bb1106c81-6d0f-4fa3-89bb-415efe980d50%7d@11
[8/24/2009 2:59:42 PM] Item isPrimary...
[8/24/2009 2:59:42 PM] GenerateThumbnail() entered...
[8/24/2009 2:59:42 PM] Video file type supported...
[8/24/2009 2:59:42 PM] executing recoder.Thumbnail()...
[8/24/2009 2:59:43 PM] Error[fileSystemWatcher_Created]: The specified module could not be found. (Exception from HRESULT: 0x8007007E)
StackTrace:
   at MediaEncoderService.Recode.Thumbnail(String mediaPath, String outputPath, TimeSpan& duration)
   at MediaEncoderService.PKSListItem.GenerateThumbnail()
   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)

 I installed PKS July beta version on win 2008 x64 and SQL 2008

Please anyone know the solution reply me as soon as possible

Aug 28, 2009 at 10:41 AM

@ scvinod - if all the functionality is working fine then I guess you can ignore this error. Also are you getting this error for every file upload or for a specific file type?

@ wezza - i guess your issue has been resolved as seen in this thread http://pks.codeplex.com/Thread/View.aspx?ThreadId=66795&ANCHOR#Post227375.