This project is read-only.

Silverlight player and Media Encoder Issue

Jun 10, 2009 at 11:35 PM

 

I am using the March release and having some issues, I would appreciate any help or suggestions.

I noticed that when I upload a video file using the silverlight uploader that the file goes to the correct place but if I use the media encoder to encode the video it returns an error.

The media encoder queue says that the Relative Path to File is undefined.

I also see that in the PKS Podcast list the Csid is not present.

I can queue up a video in the media encoder queue and make the title = mediaexample.wmv and the Relative Path to File = 686a6538-eff1-414b-aa65-32ca4d170009\a781e421-f36c-4d10-b789-4cab58d31794\7\mediaexample.wmv and it will complete the encode. But that is me manually changing the values. By default Title = 7 (or whatever ever autonumber it is on) and Relative Path to File = undefined.

But even though the encode will complete if I force it, I still have no CSid in the PKS Podcast list. 

If I view the video on the PodcastDetail.aspx page then I see that the url is:

http://<domain name>/Pages/PodcastDetail.aspx?itemId=7&userId=1&caid=&csId=%257B686A6538-EFF1-414B-AA65-32CA4D170009%257D%2540%257BA781E421-F36C-4D10-B789-4CAB58D31794%257D

But the video player doesn't show up, probably because it can't find that CSid in the PKS Podcast list.  I do see the podcaster's information, ratings and comments.

So I guess my question is why are these not being generated. I have been over the install document multiple times and everything looks good and I have successfully installed prior version but this one isn't working for me.

I would sincerely appreciate any suggestions.

Thanks

Jun 13, 2009 at 4:07 PM

Also, if I manuall put the CSid in the PKS Podcast list - %257B686A6538-EFF1-414B-AA65-32CA4D170009%257D%2540%257BA781E421-F36C-4D10-B789-4CAB58D31794%257D

then the silverlight player still doesn't work.

Jun 13, 2009 at 4:50 PM

I deactivated and reactivated the features and checked the configurations and now it generates the CSid in the PKS Podcast list for me and even makes the thumbnail, but the silverlight player doesn't actually show up when I try to view the video. It obviously finds the video though by using the CSid becauase it shows the comments and ratings, but just doesn't show the player at all.

Jul 17, 2009 at 10:42 AM

Hi becoop,

Assuming that the the CsId is now getting generated for your installation, you can try the following:

Make sure that ‘Video’ is selected in the dropdown for the Format column while uploading the wmv file.

A logic written in PKSDetailItem.xsl (Line No-229) checks the Format and the file extension of the media files and based on this the player is displayed or not shown. 

 
Logic
If Format is Audio
                And extension of files is one of these - wma,mp3,wav,aiff,bwf,ac3 then audio player will be shown.
Otherwise
If extension of uploaded file is among avi,mpg,mpeg,wmv,asf,dvr-ms,m2v,vob,mod,avs,mp4,m4v video player will be shown

-Parag

Jul 24, 2009 at 8:57 AM

I have the same or similar issue

On the PodcastDetails page none of the Web Parts above the Content Rating review results Web Part show - the rest of the site appears to be working although I have not completed my check

the url displayed is http://<site>/Pages/PodcastDetail.aspx?itemId=9&userId=15&caid=&csId=%257B0B38ADEE-67A9-4374-BF0E-07CC6373D136%257D%2540%257B9BAC5D7D-5A6E-40DE-B4E0-D6229A42AE71%257D which is consistent with that shown above.

I have checked that Video was and is selected for the Format column - it is as if the parameters are not being passed to the Web Part; the caid param is empty - should it have a value?

I cannot find anything in the documentation to set this up - there is a brief reference under Pages Configuration that states that three of the remaining pages, PodcasterDetail.aspx,Reporting.aspx and PodcastDetail.aspx are created but need to be configured. It gives the instructions for the Reporting page but not the other two.

Any help would be appreciated

Aug 3, 2009 at 11:41 AM

Hi Alan,

Content on the Podcastdetail page will appear only if the CsId value is present in the created list item. You can verify that your podcasts are having the CsId values from All Items view of the PKS Podcasts list by including the CsId column in this view. If the CsId values are not present then verify whether file has been actually uploaded in Uploadfiles folder or not. If the files are not getting uploaded, then check the Encoder.log for any errors that are logged.

If the files are not getting uploaded to the UploadFiles folder then you can try to delete and recreate the virtual directory named as “UploadFolder” within IIS Manager under Layouts -> NetworkFileStore directory of the site where PKS is deployed and set the Path to the UploadFiles folder. Check all the configuration for Media Encoder service are correct by referring the documentation. Do an IISRESET and restart the Media Encoder Service. After uploading a wmv file, verify whether file gets uploaded in UploadFiles folder or not. Then verify whether CsId value for this item is getting generated for the uploaded item. Once the CsId gets generated the content should be visible on PodcastDetails page.

Hope this helps.

-Parag

Aug 4, 2009 at 10:27 AM

Hi Parag - thanks for the reply

I have verified that the CsId is present - it is actually the same for each podcast as shown in the url in my original message - is that correct or should they be different?

I have also verified that the files are uploaded - the generated thumbnail and metadata does show on the home page and the individual item edit page - the physical path is
D:\PodCastingUploadFiles\0b38adee-67a9-4374-bf0e-07cc6373d136\9bac5d7d-5a6e-40de-b4e0-d6229a42ae71\7
reflecting the content of the CsId column and Item ID

I can access the video's from the SmartPhone page and clicking on the thumbnail runs the video in Media Player

I still cannot see the podcast on the PodcastDetails page

Aug 11, 2009 at 12:46 PM

Hi Alan,

The CsId value should be %7B0B38ADEE-67A9-4374-BF0E-07CC6373D136%7D%40%7B9BAC5D7D-5A6E-40DE-B4E0-D6229A42AE71%7D in your case.

Ensure that the above CsId value is present for all your items and then check if the player is visible on the PodcastDetails page.

 

 

Aug 12, 2009 at 7:13 AM

Hi Paraq

I can confirm that is the CsId on the podcast; the generated URL is

http://193.195.120.111:8092/Pages/PodcastDetail.aspx?itemId=18&userId=15&caid=&csId=%257B0B38ADEE-67A9-4374-BF0E-07CC6373D136%257D%2540%257B9BAC5D7D-5A6E-40DE-B4E0-D6229A42AE71%257D

I have tried replacing the generated CsId portion with the CsId in your message to remove the extra %25 characters but the result is the same - the Podcast Details page does not display properly

Unless you have any other sugestions i will try re-installing; I have to do this for the latest version anyway.

Aug 12, 2009 at 5:29 PM

Is it all file types? or only this one?  I saw this with one of the larger podcasts that I tried to upload.  Which was a wma file I then attempted a second file that was much smaller and it worked fine and the silverlight component worked fine.  I then went back and uploaded the original and it then worked.  I am curious if you find the same.

Aug 13, 2009 at 7:29 AM

The file is only around 3.5mb however - I'll give it a try.

As an update to my last entry - I have upgraded to the July release with no change - it's all working except the important bit

Aug 13, 2009 at 9:11 AM

OK - tried a small file ~400k - still no joy; but thanks for the sugestion

Apr 22, 2010 at 10:07 AM

Is there allready a solution for this problem?

May 3, 2010 at 9:50 AM
Edited May 3, 2010 at 9:54 AM

I've solved my problem by adding a default entry to the auto encode list.

  1. Go to: http://{SITEURL}/Lists/MediaEncoderAutoEncodeList/AllItems.aspx
  2. Add a new entry by clicking New;
  3. Enter the default values, mine where:
    Title TestAutoEncode
    Profile HardwareDeviceH264Small
    ListName PKS Podcasts
    FileNameFormat [Name]_h264.mp4
    Preset H264iPodClassicNano
  4. I'm not quite sure if it's needed, but do a iisreset (Windows-r, iisreset) to be sure. You should also restart the Media Encoder service!