Podcaster's Bio now showing

Apr 30, 2009 at 2:30 PM
We just deployed PKS on our sharepoint farm and I noticed that other users can not see the podcasters bio webpart on the podcast details page.  I am a farm admin and can see it with no problems.  No audiences have been setup.  Has anyone run into this issue before?
May 6, 2009 at 12:23 PM
Hi femialpha,

This seems to be a permissions issue as the authenticated users are not having "Read" permissions on the "User Information List".
I would suggest that you go through the "How To Apply Security Settings" document that is part of the PKS documentation and conifgure the security settings for your site.

Hope this helps.

Jun 17, 2009 at 6:14 PM

We had this same problem, and found that the April install and configuration document leaves out this important part (which was included in previous documents):

1.1.1     Set Permissions on the User Information List

In order to correctly display the Podcaster web part, users will need to read from the user information list.  By default they don’t have this right.

1.    On the left navigation bar under Groups, click All People.

2.    Click Settings, List Settings.

3.    Click Permissions for this List.

4.    Click the New button.

5.    Add Domain Users to the list.

6.    Grant the Restricted Read permission.

7.    Uncheck the box to send them an email, and click the OK button.