Media Encoder

Apr 28, 2009 at 11:00 AM
Hello,

Please, does someone had this same problem that I had?

I started the Media Encoder Service, and them, it stopped.
I verifyed the log and it gave me that:

[4/27/2009 11:37:40 AM] Reading configuration...
[4/27/2009 11:37:40 AM] configWeb=http://spvm
[4/27/2009 11:37:40 AM] configList=PKS Configuration Settings
[4/27/2009 11:37:40 AM] externalStoresList=PKS Media Encoder Monitor Locations
[4/27/2009 11:37:41 AM] Loading configuration from list web service...
[4/27/2009 11:37:41 AM] Configuration web service for 'PKS Configuration Settings' values have changed.
[4/27/2009 11:37:41 AM] Loading external file stores from list web service...
[4/27/2009 11:37:42 AM] External File Stores web service values have changed.
[4/27/2009 11:37:42 AM] Adding section 030abe9b-6400-45b0-897b-9c51c7a8c3ce161e3c78-2b99-4105-ba48-3027ac382c14
[4/27/2009 11:37:42 AM] Loading auto encode from list web service...
[4/27/2009 11:37:42 AM] Auto encode web service request failed.


Does someone have any idead about what is happening?
I verifyed all the steps, and everything seens to be correctly followed. That include all the pre-requisites.

Thank you.

Apr 28, 2009 at 1:08 PM
Here is the log of my event viewer:

An unhandled exception ('System.IndexOutOfRangeException') occurred in MediaEncoderService.exe [552]. Just-In-Time debugging this exception failed with the following error: Debugger could not be started because no user is logged on.

Check the documentation index for 'Just-in-time debugging, errors' for more information.
Apr 28, 2009 at 1:25 PM
I solved that.

The problem was in the PKS Configurations Settings.
I put the complete URL (not the root) of the upload path and that worked.


May 20, 2009 at 1:44 PM

I am having same issue. an you show the correct way for the PKS Configurations Settings that you used for your install?

May 21, 2009 at 9:55 AM

 

I also had the same problem and my event viewer does not show any error. Can you please show us the settings in your PKS Configuration Settings list?

My one is like this:

- Title: My Media Monitor List 


- WebID:  81927daf-8ea2-4cd3-a2fe-992ff9f72c10

- ListID: 90e63111-9072-4e09-9a48-e975542592eb

- WebURL: http://localhost

- BaseURL: http://localhost/_layouts/NetworkFileStore/UploadFolder

- ListName: PKS Podcasts

- DurationField: PodcastDuration

- DurationSecondsField: PodcastDurationInSeconds

- EfsField: PodcastFiles

 

May 22, 2009 at 4:28 PM

tomle, I don't if you changed the colunm name Podcastfiles, but my colunm name field is "Podcast Files" with the space.

It seens to be correct your media monitor list

May 26, 2009 at 11:10 AM

tomle, I am assuming that you are using the Feb or later release of PKS.

For the "EfsField" you need to provide "NFS Xml Blob" as the value. Please make this change and restart the media encoder service.

Also, please ensure that the following two values are correct in your PKS Configuration Settings list:

MediaEncoder.MonitorPath       <physical path of the upload folder>

MediaEncoder.MonitorWeb       http://<sitename>   

Hope this helps.

May 27, 2009 at 12:46 AM

Thanks, legendsofthekid and paragk for your help.

I have tried all possible values ... NFS Xml Blob, Podcast Files, etc ...and still getting the error.

I also tried Feb, March and April releases but no success!

I am not sure what i have done wrong and how come other people can get it to work!

Any clues would be very much welcome!

Thanks.

 

May 29, 2009 at 6:59 PM

i just want to know if anyone manage to find the solution for this problem or just give up?