This project is read-only.

Media Encoder Service Starts, then Stops

Apr 21, 2009 at 6:19 PM
In the event log, I see the following:

EventType clr20r3, P1 mediaencoderservice.exe, P2 1.0.0.0, P3 49d17795, P4 mediaencoderservice, P5 1.0.0.0, P6 49d17795, P7 4b, P8 0, P9 system.indexoutofrangeexception, P10 NIL.



The service is set to run as the domain administrator, and it has full access to all the db's (including the ratings db) and the sharepoint sites.
Everything looks good in the logs:
(config.log)
[4/21/2009 1:09:37 PM] Reading configuration...
[4/21/2009 1:09:37 PM] configWeb=http://podcasts.shccs.com
[4/21/2009 1:09:37 PM] configList=PKS Configuration Settings
[4/21/2009 1:09:37 PM] externalStoresList=PKS Media Encoder Monitor Locations
[4/21/2009 1:09:38 PM] Loading configuration from list web service...
[4/21/2009 1:09:38 PM] Configuration web service for 'PKS Configuration Settings' values have changed.
[4/21/2009 1:09:38 PM] Loading external file stores from list web service...
[4/21/2009 1:09:38 PM] External File Stores web service values have changed.
[4/21/2009 1:09:38 PM] Adding section 5ba7f39b-ca53-4cd2-bdb8-c65d8f8c5e7f2370596d-1d5d-49d1-a47c-507948464aab
[4/21/2009 1:09:38 PM] Loading auto encode from list web service...
[4/21/2009 1:09:38 PM] Auto encode web service values have changed.
[4/21/2009 1:09:39 PM] Progress[configTimer_Tick]: Re-reading configuration
[4/21/2009 1:09:39 PM] Loading configuration from list web service...
[4/21/2009 1:09:39 PM] Configuration web service for 'PKS Configuration Settings' values are unchanged.
[4/21/2009 1:09:39 PM] Loading external file stores from list web service...
[4/21/2009 1:09:39 PM] External File Stores web service values are unchanged.
[4/21/2009 1:09:39 PM] Loading auto encode from list web service...
[4/21/2009 1:09:39 PM] Auto encode web service values are unchanged.

(encoder.log)
[4/21/2009 1:09:38 PM] Setting up file system monitor...

(queue.log)
[4/21/2009 1:09:39 PM] Progress[webServiceTimer_Tick]: Checking for a new queued item
[4/21/2009 1:09:39 PM] Progress[webServiceTimer_Tick]: Getting next item in the queue
[4/21/2009 1:09:39 PM] Progress[webServiceTimer_Tick]: Queue entry for 'C:\UploadFiles\undefined'

It looks like it is looking to one of the sharepoint lists, and finding nothing. I've verified the settings in the Download Tracker Configuration List, the Content Rating Store Configuration Settings, PKS Podcasts, PKS Configuration Settings, and the PKS Media Encoder Monitor Locations Lists. Is there anywhere else I can look for troubleshooting, or anyone else having this problem? Server 2003 x86 - March release

Also, my SQL installation uses the instance OFFICESERVERS. I configured that in the connection strings as well.
Apr 21, 2009 at 10:13 PM
Update:
I was able to get the mediaencoderservice to run by clearning out all the podcasts and lists and recreating them. Now, whenever I click on the Silverlight or generate thumbnail button-this error pops up in the encode.log:

[4/21/2009 4:55:31 PM] Setting up file system monitor...
[4/21/2009 4:55:32 PM] GetListItem entered
[4/21/2009 4:55:32 PM] Error[GetListColumnNames]: Exception of type 'Microsoft.SharePoint.SoapServer.SoapServerException' was thrown.
StackTrace:
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at MediaEncoderService.Lists.Lists.GetList(String listName)
   at MediaEncoderService.ListWebService.GetListColumnNames(String listName)

Also, in the Media Encoder Queue, the relative path to file column is listed as "undefined". With that, the service dies. If I actually put the relative path to the file-I get the soap error above, and the service dies.

The Expression Encoder I am using is the 30 day trial, if that has any bearing.
Apr 22, 2009 at 2:38 AM
Please, verify your media encoder queue list in pks site.

If exist item without reference in PKS Podcasts list generate this error. I correct this error in my instalation deleting items without reference.