Error on install (Mar09)

Apr 17, 2009 at 9:32 AM

Hi All

Trying to install PKS as a subsite of existing Sharepoint environment following the subsite guide - and I get the following output...

Installing ISContentQueryWebparts.cab...
Installing DownloadTracking.cab...
Installing Microsoft.MSIT.Ratings.Administration.cab...
Installing Microsoft.MSIT.Ratings.Web.cab...
Installing NetworkFileStore.cab...
Installing Silverlight.cab...
Installing SharePointTagging.cab...
Installing PodcastingKitForSharePoint.wsp...
Installing PodcastingKitForSharePointUserInterface.wsp...
Activating ISContentQueryWebparts...
Activating DownloadTrackerFarm...
Activating DownloadTrackerWebApp...
Activating DownloadTrackerSiteCollection...
Error[ActivateSiteFeature]: Feature 'DownloadTrackerFeatureReceiverSiteCollection' (ID: 5247122c-6f8a-45ae-8563-45db56bf2e96) is already activated at scope 'http://portal'.
StackTrace:
   at Microsoft.SharePoint.SPFeatureCollection.AddInternal(Guid featureId, SPFeaturePropertyCollection properties, Boolean force, Boolean fMarkOnly)
   at Microsoft.SharePoint.SPFeatureCollection.Add(Guid featureId)
   at SharePointSolutionManager.PackageManager.ActivateSiteFeature(Guid feature, SPSite site)
Activating DownloadTrackerWeb...
Activating SharePointTagging...
Activating Network File Store...
Activating ContentRatingFeatureFarm...
Activating ContentRatingFeatureWebApplication...
Activating Ratings Control...
Activating RatingsModification...
Activating PKS.SiteColumns...
Activating PKS.PodcastContentType...
Activating PKS.PodcastList...
Activating PKS.MediaEncoderMonitorLocations...
Activating PKS.SeriesContentType...
Activating PKS.SeriesList...
Activating PKS.NavigationContentType...
Activating PKS.EncoderQueueList...
Activating PKS.UserInterface...
Activating PKS.SubSitePages...
Error[ActivateWebFeature]: Failed to instantiate file "PKSMobileHome.aspx" from module "PKSMobileContentPages": The specified list does not exist.
StackTrace:
   at Microsoft.SharePoint.Library.SPRequest.EnableModuleFromXml(String bstrFeatureDirectory, String bstrUrl, String bstrXML)
   at Microsoft.SharePoint.SPModule.ActivateFromFeature(SPFeatureDefinition featdef, XmlNode xnModule, SPWeb web)
   at Microsoft.SharePoint.SPModuleElement.ElementActivated(SPFeaturePropertyCollection props, SPSqlCommand sqlcmdAppendOnly, SPWebApplication webApp, SPSite site, SPWeb web, Boolean fForce)
   at Microsoft.SharePoint.Administration.SPElementDefinitionCollection.ProvisionModules(SPFeaturePropertyCollection props, SPSite site, SPWeb web, Boolean fForce)
   at Microsoft.SharePoint.Administration.SPElementDefinitionCollection.ProvisionElements(SPFeaturePropertyCollection props, SPWebApplication webapp, SPSite site, SPWeb web, Boolean fForce)
   at Microsoft.SharePoint.SPFeature.ProvisionElements(SPFeaturePropertyCollection props, SPWebApplication webapp, SPSite site, SPWeb web, Boolean fForce)
   at Microsoft.SharePoint.SPFeature.Activate(SPSite siteParent, SPWeb webParent, SPFeaturePropertyCollection props, Boolean fForce)
   at Microsoft.SharePoint.SPFeatureCollection.AddInternal(Guid featureId, SPFeaturePropertyCollection properties, Boolean force, Boolean fMarkOnly)
   at Microsoft.SharePoint.SPFeatureCollection.Add(Guid featureId)
   at SharePointSolutionManager.PackageManager.ActivateWebFeature(Guid feature, SPWeb web)
Activating PKS.NavigationList...
Activating PKS.MediaEncoderAutoEncode...
Activating PKS.PodcastListActivationHandler...
Adding web.config keys...

As a result of this, when trying to activate the "PKS Pages" feature, I then get an error "Failed to instantiate file "PKSMobileHome.aspx" from module "PKSMobileContentPages": The specified list does not exist".

Any ideas what I can do? Ive tried deinstall and reinstall with no change. Our platform is Server 08 x64, with Sharepoint Server 07 x64.


Many thanks

Apr 17, 2009 at 12:17 PM
Hi Stuart,

It seems that while creating the subsite you have not selected the "Pulishing site" template.
Can you try again and install PKS on a subsite which was created using a Publishing site template?

Hope this helps.
Apr 17, 2009 at 12:34 PM
Edited Apr 17, 2009 at 1:19 PM

HI Paragk

 

It definitely was a publishing site template used. I thionk ive kinda managed to sort it though – not very tidy however!

 

What I did was issue the install command to http://portal (our root site) and ignored the errors. Then I issued the install command again, this time to http://portal/gallery (our indentened PKS subsite). This appears to have worked properly – again I have ignored the errors, but i can complete the configuration now.

 

Weird!

 

Apr 17, 2009 at 1:19 PM
Ok - further to my above post... found a few more odd ones while doing the configuration which I hope someone can help me with.

In the guide...
 

Configuring the Podcast List for Sub Site

The podcast list created during the installation, “PKS Podcasts”, needs to have the Rating component enabled, the column “Podcast Files” configured and the appropriate edit permission set.

1.       Go to Sub site. In the Settings > List Settings for the PKS Podcasts list, click the Ratings link in the “Communication” section.

2.       Check Enable Rating for this List and then Save & Exit.

3.       In the Settings > List Settings for the PKS Podcasts list, click the Download Tracking link in the “Communication” section.

4.        Check Enable Download Tracking for this list and then Save & Exit.

5.       Go back to the settings for the PKS Podcasts list, click Podcast Files in the Columns section.

6.       Delete the column.

7.       Create new Column named as PodcastFiles of Type Network File Store.

8.       Rename this column to Podcast Files.

9.        In the  Advanced Settings under the General Settings section, change the Edit Access to “only their own

10.   Click OK.

I can successfully see both "Enable Rating" and "Enable Download Tracking"  where they should be - and can use the "Enable Rating" option. However, when I try to enable the tracking - I get a "Value does not fall within the expected range." error message. Any ideas?