Encoder Error[fileSystemWatcher_Created]

Feb 18, 2009 at 9:56 AM

Hi
I am installing the December release on a 2003 server with SQL Server Express edition, all on a virtual server.
Things are working fine except that I get this error in the encoder.log:
I get a similar error both when I upload a file and after encoding.
Thoughts ?  Ideas ?
regards
/Lars

 

[2009-02-18 11:35:50] Monitor Location found: PKS Podcasts
[2009-02-18 11:35:54] Thumbnail generated at: C:\UploadFiles\385b2299-7f7f-498a-bbae-0f121c76a5fb\848d4c76-8539-41fc-9203-d3ea2962c03f\fce7f617-5b25-4f52-a5b9-5b2aad9483e4
[2009-02-18 11:35:54] Duration: 00:00:11.5440000
[2009-02-18 11:35:54] Connecting to web service: http://expo
[2009-02-18 11:35:54] GetListItem entered
[2009-02-18 11:35:54] Parameters set
[2009-02-18 11:35:54] GetListColumnNames: 71
[2009-02-18 11:35:54] Error[fileSystemWatcher_Created]: Object reference not set to an instance of an object.
StackTrace:
   at MediaEncoderService.ListWebService.GetListItem(String itemId, String listName, String fieldDisplayName, String& id)
   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)

[2009-02-18 11:35:54] Item created: C:\UploadFiles\385b2299-7f7f-498a-bbae-0f121c76a5fb\848d4c76-8539-41fc-9203-d3ea2962c03f\fce7f617-5b25-4f52-a5b9-5b2aad9483e4\Thumbnail.jpg
[2009-02-18 11:36:05] Progress[webServiceTimer_Tick]: Checking for a new queued item

Apr 3, 2009 at 7:26 PM
I am getting the same error, but it only happens on larger files, anyone have any advise on this???
May 20, 2009 at 6:32 PM

We are getting this same error, and it is driving me crazy. 

~~~~~~~~~~~~~~~~~~~~~~~

[5/20/2009 1:58:21 PM] Error[fileSystemWatcher_Created]: Object reference not set to an instance of an object.
StackTrace:
   at MediaEncoderService.MediaEncoderService.ActOnNewFile(String fullPath)

~~~~~~~~~~~~~~~~~~~~~~~

 

Only for large files, doesn't matter on file type.  The file gets uploaded to the network share, but no thumbnail is created, and it doesn't even show the player when you click on this podcast page.  I have dug through logs, and now the source code (Got to MediaEncoderService.cs - but can't really get any further without debugging and setting breakpoints in our dev. environment.)  I have looked at all the settings I can find, seeing if it was a timeout somewhere, but just can't find it.

 

Any guidance would be helpful.  All other video's seem to be ok.  When talking about 130 megs or less (give or take'ish)

 

Jun 1, 2009 at 1:38 AM

I am having the same issue and it is preventing us from going live.  Issue appears when large files over 100meg (not sure the exact threshold) are uploaded to the site.  Is there some time limit set on the filesystem watcher that might be causing this?