Cannot display avi files

Dec 2, 2008 at 1:35 PM
Hi
I'm using PKS September release with 2008 server.
The problem is when I upload a video file with .avi format I cannot display it with silverlight player.
I know that silverlight cannot play avi files and Expression encoder have to convert it.
Ilooked at the Media Encoder Service and saw that it is supposed to be converting the video files.
But when I debug Media Encoder Service  I saw that fileUrl always return empty. Am I doing something wrong?

string

fileUrl = lws.GetNextQueueItem(out id);


By the way my web service (lws) url is http://{site}/_vti_bin/Lists.asmx and I can display it from browser.

 

Dec 2, 2008 at 5:24 PM
Hmmm... interesting.  I thought AVI files would work, as they are listed inthe supported files in the .config file.
I am using the HTTP Post method for uploading, and although VERY slow, it seemed to upload OK.
The Media Encoder log detected it, generated the directory, and claims to have generated the thumbnail (though I don't see it).
Then it throws an error:  "Length cannot be less than zero."

Strange.  Does this simply not accept AVI files?  Should it be removed from the AcceptedTypes in the config file?
Dec 4, 2008 at 6:52 AM
I realised that I forgot to put "Re-encoding link to the page.
Re-encoding link solved my problem now :)
It works perfectly
Dec 8, 2008 at 12:21 PM
So to successfully upload an AVI file, podcasters have to upload it, navigate to the podcastdetail page, and manually hit the "re-encode for silverlight" button?
Is there a way to automate this?