Oct 2008 release - Problem Podcastdetail.aspx page

Nov 29, 2008 at 2:52 PM
I just finished installing the October release - went already a lot smoother allthough I had to change some stuff to get it to work in a non-root site collection. Unfortunately the Podcastdetail.aspx page gives me an error saying -

Parser Error Message:
Unknown server tag 'asp:MediaPlayer'.

The uploader control seems to work fine though so I guess that I'm using the correct version of Silverlight (I have the RTW version installed). Any thoughts?



Dec 3, 2008 at 5:10 PM
I solved this one myself - since the complete installer did not work for me I manually installed and activated features by creating a new XML file for the SSM.exe tool. Apparently I forgot to deploy the Silverlight.cab solution package which contains the mediaplayer control.

Rgds,

Joris
Feb 4, 2009 at 12:08 AM
Hi Joris,

i am having the same problem like you had.
The difference is, i have deployed the SilverLight.cab. i can see it is "Globally Deployed" in Central administration - operation - solution management.

The uploader control is running ok.
File is uploaded succefully, thumnail is appearing, duration and the file size are appearing correctly.

Am i missing somthing?

Thanks.
Feb 4, 2009 at 1:18 AM
I solved this one myself.
I added "<add tagPrefix="asp" namespace="System.Web.UI.SilverlightControls" assembly="System.Web.Silverlight,Version=2.0.5.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />"

in the <Controls> section.


Rgds,

on3