This project is read-only.

Problem playing video through internet URL

Nov 27, 2008 at 4:46 PM
I have configured october release of PKS and i am able to upload audio and video files through both internet and intranet links. When i try to play the video using the intranet link it works fine but at the same time internet link for podcast detail page throws error (An unexpected error has occured). If anyone has came across this issue, please suggest an work around.
Nov 27, 2008 at 5:28 PM
Hi, dyuvraj

The problem may be that when you installed PKS, all the configs, Media Encoder.config, PKS Configuration List, PKS Media Encoder Monitor Locations List, and the podcast columns were setup to point to the inertal URL. You can update these to the extranl URL and begin using only the external URL and all should work.

As a cuation this will solve the video playing through the internet URL problem but won't solve the ratings bug. If you are ready to go live now one work around would be to update the PKSItem.xsl and PKSDetailItem.XSL and remove the references to the ratings component. This will cause the internet site to work, ratings will in effect be disabled so now errors will be thrown.

Thanks,
-a







Dec 2, 2008 at 1:04 PM

All config files & lists are refering the internet URL. It is working for me only when i remove content Rating-Review Results webpart in the podcastdetail page.

One more issue: Podcasters info & Co-Podcasters info are getting displayed only to the site collection administrators. When a site owner try accessing the application, Podcasters info & Co-Podcasters section throws the following error,

"Unable to display this Web Part. To troubleshoot the problem, open this Web page in a Windows SharePoint Services-compatible HTML editor such as Microsoft Office SharePoint Designer. If the problem persists, contact your Web server administrator."

Regard's
Yuvaraj
Dec 2, 2008 at 2:06 PM
With regards to the Podcasters and Co-podcasters, you need to grant the user accessing it read (or restricted read) access to the User Information List.  If suitable, you could add All Authenticated Users as restricted readers.

Regards,

David.
Dec 2, 2008 at 2:33 PM
I have added all the authenticated users as restricted readers but still i am getting the same error when i login with an user id having restircted reader access.