This project is read-only.

Media Encoder Service Issues

Nov 17, 2008 at 8:11 PM
I'm running into an issue installing on Windows Server 2003 x64 service pack 2.  I can't seem to get the media encoder service to start.  It gives me the dreaded "The media encoder service on local computer started and then stopped.  Some services stop automatically, yada yada yada."

The encoder.log file shows:

[11/17/2008 2:49:02 PM] Configuration web service request failed.
[11/17/2008 2:49:02 PM] Setting up file system monitor...
[11/17/2008 2:49:33 PM] Starting Media Encoder Service...
[11/17/2008 2:49:33 PM] Reading configuration...
[11/17/2008 2:49:33 PM] configWeb=http://podcasting/
[11/17/2008 2:49:33 PM] configList=PKS Configuration Settings
[11/17/2008 2:49:33 PM] externalStoresList=PKS Media Encoder Monitor Locations
[11/17/2008 2:49:33 PM] Loading configuration from list web service...
[11/17/2008 2:49:34 PM] Error[LoadConfiguration]: The request failed with HTTP status 401: Unauthorized.
StackTrace:
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at MediaEncoderService.Lists.Lists.GetListItems(String listName, String viewName, XmlNode query, XmlNode viewFields, String rowLimit, XmlNode queryOptions, String webID)
   at MediaEncoderService.ListWebService.LoadConfiguration(String listName, String& rawXML, Hashtable& configuration)

[11/17/2008 2:49:34 PM] Configuration web service request failed.
[11/17/2008 2:49:34 PM] Setting up file system monitor...

So I checked the IIS logs, and they show these 401 entries:

2008-11-17 20:05:03 W3SVC1434982331 172.16.40.195 POST /_vti_bin/sitedata.asmx - 80 - 172.16.40.195 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.3053) 401 2 2148074254
2008-11-17 20:05:03 W3SVC1434982331 172.16.40.195 POST /_vti_bin/sitedata.asmx - 80 - 172.16.40.195 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.3053) 401 1 0
2008-11-17 20:05:03 W3SVC1434982331 172.16.40.195 POST /_vti_bin/sitedata.asmx - 80 - 172.16.40.195 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.3053) 401 1 2148074252

I'm changed accounts on the service, reinstalled the service, etc.  Can anyone help with this issue or explain why this service is making POSTS to a _vti_bin directory?


Nov 18, 2008 at 1:36 PM
I would like to know the answer to this question as well
Nov 18, 2008 at 8:51 PM
Edited Nov 18, 2008 at 9:07 PM
I have the same issue. 

Allowing Anonymous access, via IIS Manager, for the SP web site got the service to start, but there are still WS/SOAP errors similar to the one mentioned above.  Does the encoder have Windows Integrated authentication enabled to allow the service account's credentials to be used when logging into SP?
Nov 18, 2008 at 9:44 PM
It appears the account that is running the service does not have access to the SharePoint list.

As a general best practice for PKS the same account with elevated privileges should be, the configured account for the default app pool, a DBO on the Ratings Store, the configured account for Media Encoder Service and a site collection administrator.

Thanks,
-a

Nov 18, 2008 at 9:47 PM
Yeah, funny thing is, all of those things are true, especially given that the account is the primary "administrator" account for the system, and the one that I'm using to install everything.
Nov 19, 2008 at 9:12 PM
I've been banging my head over this for the past 24 hours now.  My environment is:

VirtualPC 2007
Windows Server 2003 Enterprise Edition with SP2
all of the latest Windows Server 2003 relevant Windows Update patches applied
Domain Controller (domain named MOSS)
SQL Server 2005 with SP2
MOSS 2007 with SP1

I have been testing/installing everything using the MOSS\Administrator account (the domain administrator account).  The MOSS services, application pool, encoder services, etc. are all configured to use that account.  I'm consistently getting a 401 unauthorized error from the encoder service upon start-up by the time I hit page 12 of the quick install guide.  From the encoder log file, this occurs when trying to access the PKS Configuration Settings list. 

I swear I've flipped every switch possible, and have come up empty.  I really want to use this for a project, and potentially contribute to the project in general going forward, but the fact that I can't even get it installed and configured is somewhat troubling for me.  I'm not a MOSS novice, nor a novice in general.  And since at least one other person is experiencing the same issue, I feel somewhat more confident that I'm not completely a lost cause.  I'm just hoping that my configuration rings a big "ah-ha" from someone reading this.
Nov 20, 2008 at 2:24 PM
Yeah I am right here hoping for a DAH it is this? I may start from scratch again unless a solution to this question gets anwered
Nov 21, 2008 at 5:20 PM
So even though I have not figured out how to fix the issue, I believe I have figured out what the root cause is.  While the server's name is SHAREPOINTDEV, the test site's name is PKS.  There appears to be a trust issue with passing NTLM credentials from the Encoding Service to a "random" web site named PKS.  You can override this in IE by adding that host to your trusted list, but I haven't figured out how to do that such that a service can also trust a "random" web site.
Nov 22, 2008 at 6:26 PM
If you need to override "PKS" it's possibly a symptom of a config not be correctly set. Verify the media encoder.config file, verify the media encoder monitor locations list settings, verify the PKS Podcasts List, Podcast Coloum settings, and verify the PKS Configration list settings looking for any instance or reference to PKS.

BigJimDc, Neoninbiz, Stukes501 - Are using the Sept, or Oct builds? If not on October yet, at a minium I would try to download the Oct Build, install and install the new media encoder. Don't forget the new version of the media encoder pulls config from a SharePoint list so you will need to create a new list from the list template in the install directory.
Nov 24, 2008 at 5:56 PM
I'm using the Oct build.  As for the configuration list settings, the authentication error is received when trying to retrieve those settings from the list, thus those settings are not even being read.  The settings in the encoder service's .config file are simple and straight forward.  As I said, this simply appears to be a trust issue that I'm still researching how to get around.  I'm just about ready to install PKS to the default "SHAREPOINTDEV" host name, just to prove that this is definitely the issue.  That doesn't solve my issue, but it would at least prove that's what the issue is.
Nov 24, 2008 at 6:19 PM
Maybe we can get a good example of a working config file that users can see besides what is in the instructions?
Nov 24, 2008 at 9:55 PM
Having just re-installed this to the SHAREPOINTDEV host name (i.e., the default, non-host-name-header configured web site which matches the machine name of the computer), the encoder service starts up as expected.

I'm chalking this up to simply being insurmountable security issues given the above referenced configuration.  I'm sure that if you have a "real" environment with proper security trust rules in place, this won't be encountered.  I'm still curious how to force the NTLM credentials to be passed from the encoding service to SP, but for now it's not a show stopper on my end.

Now off to debug some new things...
Feb 18, 2009 at 10:03 PM
I also came across this exact same issue and found a solution + explanation.

Turns out its a security 'feature' in .NET framework 3.5 SP 1. see here for an explanation: http://www.crsw.com/mark/Lists/Posts/Post.aspx?ID=44

If you just want the fix see here: http://support.microsoft.com/default.aspx?scid=kb;EN-US;896861 (Method 1)

I normally find I have to do this to get search indexing as well.
Feb 20, 2009 at 1:25 PM
Thanks ztsmith, solved my problem of not being able to start the MediaEncoder service. Funilly enough, I'd applied this very fix a week or so again on a Sharepoint farm to get indexing working properly and never put 2+2 together to fix this!
Oct 3, 2009 at 10:38 AM

Thanks for the explanation... I performed these steps to counter the security feature and it still didn't work. After looking at the log I was still getting the same errors.

So I went into the central administrator, Application Management tab, and went to the Authentication providers under Application Security Section.

I switched to the my podcast site. Edited the default record and under the IIS Authentication Settings section, I rechecked the windows authentication checkbox...

I had originally unchecked this box to get around the problem mentioned above.

I tried to start the service at that point and VIOLA!!

Cheers!