PodcastSearchResults.aspx returns: Property doesn't exist or is used in a manner inconsistent with schema settings

Nov 15, 2008 at 4:06 PM
Anytime I click on a tag or category (say in this case "google"), I get the following error returned by the aspx page:

Property doesn't exist or is used in a manner inconsistent with schema settings 

Here's an example of the url:
http://.../Pages/PodcastSearchResults.aspx?s=Podcasts&k=google&PageGUID=65885fb4-de29-4a79-ba40-45a112cd7b02&WebGUID=762832f9-48a2-4cd2-8742-540585d2c61a


(scope podcasters works though)
Nov 15, 2008 at 4:30 PM
BTW, not sure if it's related, but the install document talks about a mapping property "ows_CoAuthorIds(Text)" (page 15) which doesn't exist. I see all the other properties, but not this one.
Coordinator
Nov 18, 2008 at 7:29 PM
If you perform a search on Podcasts or Podcasters I am guessing you get the same error, correct? If so verify that the site has been indexed during the setup and that it was indexed after you added new content.

I will verify the CoAuthorID issue.
Nov 24, 2008 at 9:24 PM
Actually the podcasters search works just fine, only the podcasts search fails. I've reindexed all the site, with no error in the logs. Did you get a chance to check whether I'm supposed to see a CoAuthorId mapping, or if it's just a documentation error?

Herve
Dec 3, 2008 at 7:05 PM
The bug fix trick has been posted here. Hopefully this fix will find its way into the next release (hint hint hint) ;o)
Jan 12, 2009 at 4:01 AM
Has anyone figured out the CoAuthorID issue? I installed the latest release and yet couldn't find CoAuthorID.
Coordinator
Jan 12, 2009 at 4:01 PM
Some properties do not show up correctly until data has been added. Try to upload a podcast with both an author and multiple co-authors, then try to rate it and download it. My guess is that it will then show up in the search mappings.
Jan 13, 2009 at 6:18 PM
You are right. It did show up this time. Thanks.