Thumbnail not generated

Nov 13, 2008 at 9:36 AM

I have configured PKS Oct 2008 release and i am able to upload video & audio files successfully but at the same time thumbnail is not getting generated. Please find the error below which i have found in the event viewer.

Error:

Event Type: Error
Event Source: Windows SharePoint Services 3
Event Category: General
Event ID: 6875
Date:  11/13/2008
Time:  3:36:22 PM
User:  N/A
Computer: CTSINTBMCHPW
Description:
Error loading and running event receiver UpdateDurationThumbnailHandler.UpdateDurationThumbnailHandler in PKS.UpdateDurationThumbnailHandler,Version=1.0.0.0, Culture=neutral, PublicKeyToken=3a737f14c332a521. Additional information is below.

: Object reference not set to an instance of an object.

Please advice me to fix this issue.

Coordinator
Nov 13, 2008 at 8:24 PM

First step, can you verify if thumbnail.jpg exists in the file system. (example C:\UploadFiles\GUID\GUID\thumbnail.jpg)

 

Also are you installing to the root or a sub site?

Nov 14, 2008 at 8:11 AM
1) There is no thumbnail exist in the file system
2) I am installing it in the root site.
Nov 14, 2008 at 8:58 PM
I'm having the same issue, only I don't even have the error log...
Nov 17, 2008 at 5:27 AM
Even i don't have any error log but i took the above log from the event viewer application error log.
Nov 17, 2008 at 11:53 AM

Can you verify the following

  • Time interval for media encoder (MediaEncoder.ConfigInterval) is set to 1 hour (i.e. 36,00,000 miliseconds) in PKS Configuration Settings List.

Restart Media encoder service & upload again

Nov 17, 2008 at 11:58 AM
Edited Nov 17, 2008 at 12:37 PM
Changed the value of MediaEncoder.ConfigInterval to 36,00,000 and then uploaded a video file after restarting the Media encoder service but the result is same.
Nov 17, 2008 at 4:48 PM
Actually that fixed the problem for me. Although I added one more change, so not sure which one fixed it. I noticed that "PKS Configuration Settings List" was only accessible for the person who installed PKS. I made the list visible to all, and there you go!
Nov 17, 2008 at 4:51 PM
And it's not 36,00,000 but 36,000,000 (36000000)
Nov 18, 2008 at 4:56 AM
It is working fine. Value of MediaEncoder.ConfigInterval is 36,00,000 not 36,000,000.
Nov 27, 2009 at 10:17 AM

Dear Sirs,

PKS Site is at Root.

Changed the MediaEncoder.ConfigInterval to 36,00,000 in PKS Configuration LIst.

Inherited permissions at PKS Configuration List as well.

Result is: Feetting Event ID: 6875 & exactly Same description as above post.

Also, Thumbnail not generated in File System.

Please help me out.

 

 

Nov 27, 2009 at 10:19 AM

Dear Sirs,

Also please note the Event ID is generated every time i upload the Video in PKS & it generates 3 times for every upload.

Kindly suggest.