Media Encoder problem with October Beta

Nov 12, 2008 at 7:55 PM
Ok, so I am feeling that something is out to get me and drive me bananas.

I installed the October Beta on a different Sharepoint environment.  Got to starting the Media Encoder service and it says:

Service cannot be started. System.ArgumentException: The path is not of a legal form.
   at System.IO.Path.NormalizePathFast(String path, Boolean fullCheck)
   at System.IO.Path.NormalizePath(String path, Boolean fullCheck)
   at System.IO.Path.GetFullPathInternal(String path)
   at System.IO.Path.GetFullPath(String path)
   at System.IO.FileSystemWatcher.StartRaisingEvents()
   at System.IO.FileSystemWatcher.set_EnableRaisingEvents(Boolean value)
   at MediaEncoderService.MediaEncoderService.MonitorFileSystem()
   at MediaEncoderService.MediaEncoderService.OnStart(String[] args)
   at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)

Now, I am not brainless :)  I verified all URLs, URIs, permissions, Virtual Directories, MediaEncoderService.exe.config and all config items from the document.  My external directory is C:\UploadFiles and the URL is http://pkstest.cyberplex.com/UploadFiles/.  I have checked, re-checked etc and still cannot start the service. (this was never an issue with the Septemeber beta for me - I do realize that the configs have changed but that all went well when I installed Oct)

Ideas?
Coordinator
Nov 12, 2008 at 10:03 PM
 

This error is likely being caused by the monitor path location being set incorrectly. Verify the MediaEncoder.MonitorPath location in the PKS Configuration Settings list. Also if it looks correct verify there aren't any extra spaces at the end of the path.

 

Thanks,

-a