MediaEncoder Installation Error

Oct 15, 2008 at 10:49 PM
Hi all -

I am upgrading from the August Release, and have been following the upgrade documentation to the letter.  Everything seems to be going smoothly, but I've hit another roadblock:

I just finished deploying the September Release, and the only errors in the logfile mentioned four CAB files that already existed.  I assume that's OK, and that they are leftover from the August installation, and will continue to function properly.  The deployment continued and finished, with no further errors.

Next, I went to run the installer for the new MediaEncoder Service.

The installer started normally, and began to run.  Then it prompted me to create credentials for the service.  I entered some values, but no matter what I chose for a username/psswd, I always get the following error:

Error 1001.  No mapping between account names and security IDs was done.

I click OK, and the installation fails and goes no further.

Has anyone run into this issue?
I'd appreciate any guidance.

Thanks!
Bobby
Coordinator
Oct 16, 2008 at 2:55 PM
Hi Bobby, the MediaEncoder dev is looking into this and should provide some guidance shortly. Thanks for your patience.
Developer
Oct 16, 2008 at 5:37 PM
Hi Bobby,

I have a couple things you can try.  The first question is which account are you using credentials for.  In the case of the media encoder service you need to use an existing account on your system.  This account needs to have read and write access to the Podcast Lists that you define in the configuration.  The account also needs to have log on as a service for an account policy rights.  Using the web service application pool ID is one way to accomplish this as it should have the proper service rights and can easily be configured to have the proper SharePoint security rights if it does not by default.  The other thing I would verify is to verify that you are installing as an administrator on the server.  If you are still running in to issues let us know and we can try to dig deeper, but from the error message you are receiving it appears that the installer is failing to create the service entry which causes the whole installation to rollback.
Oct 20, 2008 at 8:33 PM
Thanks for your responses!

kbunge:  I was under the impression that I was creating a NEW username/password.  Clearly, I was mistaken, and that's certainly why the installation wouldn't continue.  I went back into the server to try again, using our service account credentials, but now when I try to run the installer, it says that another instance of the installer is in process, and I'll need to stop that one before continuing.  I don't know where this other instance is coming from, and I don't see anything obvious in the Task Manager.

Any thoughts on how to abort whatever installations are in progress, or giving the new instance a higher priority?

Thanks!
Developer
Oct 21, 2008 at 8:34 PM
Well I suppose the first thing I would check under task manager is for an msiexec process.  You will likely have to do this as an administrator and show all processes to ensure you catch it.  If you don't see an msiexec process then I'd suggest a reboot if that is possible as it should clear things up.  If neither of those clears things up we'll do a little more digging.
Feb 5, 2009 at 9:19 PM

Hi everyone,

I've encountered a slightly different issue when trying to install the Media Encoder Service. When I enter the Application Pool credentials during the install, I see the following error:

"Error 1001: The Specified Service already exists"

Per kbunge's comments above, I've tried different sets of credentials that all have R/W acces to the necessary Podcast lists, and are "service accounts" that should have the appropriate policy rights. I may be missing something here, but would welcome any comments or pointers from folks who've tackled this already.

Thanks in advance

 

Feb 10, 2009 at 11:49 AM
Have you tried to remove the "Media Encoder Service" in add/remove programs then restart the installation?
Feb 10, 2009 at 4:54 PM

I've checked this out, but have never found Media Encoder Service in the Add/Remove Programs control panel (presumably because the original installation never completes). I've also checked to see if any Encoder Service processes are running, but don't see anything that would indicate this is running.

Feb 10, 2009 at 5:36 PM
Check for the existence of the following:
  1. in services, "Media Encoder"
  2. on your server, c:\program files (x86)\PKS OR c:\program files\PKS
  3. in the registry [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{98527B3E-DEE7-4E9B-B736-158E93E2433E}]